Results 1 to 6 of 6

Thread: Has anyone installed KeepNote ?

  1. #1
    Senior Member
    Join Date
    Nov 2011
    Posts
    123

    Has anyone installed KeepNote ?

    Does anyone have experience installing KeepNote with Knoppix?

    http://keepnote.org/index.shtml#download

    http://keepnote.org/download/keepnote-0.7.4/INSTALL

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    509
    Download the Linux Debian package keepnote_0.7.6-1_all.deb to your Downloads directory. Open a terminal and issue
    Code:
    cd /home/knoppix/Downloads
    sudo dpkg -i keepnote_0.7.6-1_all.deb
    If there are additional packages needed on your system you will get an error message that tells you more. If the installation procedure was successful you can find KeepNote in the menu with office applications.

  3. #3
    Senior Member
    Join Date
    Nov 2011
    Posts
    123
    Thanks - I downloaded the .dev and noticed that the download created a "Download" directory with an uppercase D. Doing the Sudo dkpg command gave dependency errors as expected.

    I changed back to the /home/knoppix directory and tried the following:

    apt-get install python python-gtk2 python-glade2 libgtk2.0-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python-glade2 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'python-glade2' has no installation candidate
    E: Unable to locate package libgtk2.0-dev
    E: Couldn't find any package by regex 'libgtk2.0-dev'

    = = =
    I also tried:

    apt-get install python-gnome2-extras
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python-gnome2-extras is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'python-gnome2-extras' has no installation candidate

    = = = =
    Started synaptic package manager again and received the following message:
    "You have 1 broken package on your system! Use the "Broken" filter to locate it." - I didn't get that message before when I entered the synaptic package manager, so the good news is that I'm having some effect.

    The Broken filter shows the keepnote package with a red left box.

    Suggestions? - Thanks.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    509
    Since the package python-glade2 really exists in the Debian package repository I would suggest that you issue
    Code:
    sudo apt-get update
    sudo apt-get -f install
    If this gives an error message about version issues you could try
    Code:
    sudo apt-get -t testing install python-glade2

  5. #5
    Senior Member
    Join Date
    Nov 2011
    Posts
    123
    ... continuing

    [previous lines omitted]

    Processing triggers for python-support ...
    Processing triggers for python-central ...
    root@Microknoppix:/home/knoppix# sudo apt-get -t testing install python-glade2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libc6-dev : Breaks: gcc-4.6 (< 4.6.0-12) but 4.6.0-10 is to be installed
    E: Broken packages
    root@Microknoppix:/home/knoppix#

  6. #6
    Senior Member
    Join Date
    Nov 2011
    Posts
    123
    With klaus2008's help, I did get Keepnote installed. Sorry I put some on the information on the Firefox / Iceweasel thread:

    http://www.knoppix.net/forum/threads...599#post125599

    There may be some overlapp in what is needed and issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •